Can not run Delivery Person app.

Hi guys,

I can not run the app. Here is the video that reproduced my process. Please check it out.

Did you download the latest version on Codecanyon?

please check the video

Could you provide me the Xcode version on your computer?

My version is 13.2.1 (13C100)

In folder ios could you try delete:

In the root delete file: yarn.lock

then try re-run?

Just reinstalled pod. But I got the same error.

Can you please remote to my desktop?

I just download the code on Codecanyon and run it.

https://drive.google.com/file/d/19UteWQNU76dtrIrLHIdrxhnO-qB74gtV/view?usp=sharing

node -v
v16.13.1

npm -v
8.1.2

I think your computer cached the old version please try to do the steps I mention above.

I download the latest version on Codecanyon. Then I follow your steps and did exactly like that. But I got the same error.

I run the template react native and it works fine on my mac.

Could you try:

In the file: ios/Podfile

Change to

pod 'OneSignalXCFramework', '>= 3.0', '< 4.0'

And file:ios/OneSignalNotificationServiceExtension/NotificationService.m

Replace with:

#import <OneSignal/OneSignal.h>

#import "NotificationService.h"

@interface NotificationService ()

@property (nonatomic, strong) void (^contentHandler)(UNNotificationContent *contentToDeliver);
@property (nonatomic, strong) UNNotificationRequest *receivedRequest;
@property (nonatomic, strong) UNMutableNotificationContent *bestAttemptContent;

@end

@implementation NotificationService

- (void)didReceiveNotificationRequest:(UNNotificationRequest *)request withContentHandler:(void (^)(UNNotificationContent * _Nonnull))contentHandler {
    self.receivedRequest = request;
    self.contentHandler = contentHandler;
    self.bestAttemptContent = [request.content mutableCopy];
    
    //If your SDK version is < 3.5.0 uncomment and use this code:
    /*
    [OneSignal didReceiveNotificationExtensionRequest:self.receivedRequest
                       withMutableNotificationContent:self.bestAttemptContent];
    self.contentHandler(self.bestAttemptContent);
    */
    
    /* DEBUGGING: Uncomment the 2 lines below and comment out the one above to ensure this extension is excuting
                  Note, this extension only runs when mutable-content is set
                  Setting an attachment or action buttons automatically adds this */
    // NSLog(@"Running NotificationServiceExtension");
    // self.bestAttemptContent.body = [@"[Modified] " stringByAppendingString:self.bestAttemptContent.body];
    
    // Uncomment this line to set the default log level of NSE to VERBOSE so we get all logs from NSE logic
    //[OneSignal setLogLevel:ONE_S_LL_VERBOSE visualLevel:ONE_S_LL_NONE];
    [OneSignal didReceiveNotificationExtensionRequest:self.receivedRequest
                       withMutableNotificationContent:self.bestAttemptContent
                                   withContentHandler:self.contentHandler];
}

- (void)serviceExtensionTimeWillExpire {
    // Called just before the extension will be terminated by the system.
    // Use this as an opportunity to deliver your "best attempt" at modified content, otherwise the original push payload will be used.
    
    [OneSignal serviceExtensionTimeWillExpireRequest:self.receivedRequest withMutableNotificationContent:self.bestAttemptContent];
    
    self.contentHandler(self.bestAttemptContent);
}

@end

Finally npx pod-install and run the app again.

I got this error.