Cirilla - Multipurpose Flutter Wordpress App & App Builder was release

2 Likes

Hi, i have a problem with my code purchase “The license code not validate.”

had the same issue and solved it. first, you validate from the author’s site, then copy again FROM the author’s website to your dashboard (you’ll notice that the purchase code is shortened), validate and you should be good

@Doxec

Could you check it Register License – Appcheap

The Cirilla register on admin.appcheap.io

Hi, first off, this is a powerful release. i have a minor issue with the app loading only the logo, i know where my personal confusion is. in your documentation you mention an “api.js” file which is currently not in directory (a part in the documentation talking about Rest Api ).so instead after a search i found ap “app.js” file to change those. So, please kindly guide on this if its just the misnaming the necessary file or otherwise. Thanks, so far in my pocket i have 4 stars, one more when this loads. cheers

1620182104644

sign in with your Envato account >>> register app >>> insert your licence code THEN COPY AGAIN FROM that https://admin.appcheap.io/, then paste in your dashboard to verify

@Bionick_Tales
Did you use this Update Rest API keys – Appcheap

For documentation and API?
Please let us know if there are any issues.

@ngocdt ter activating my code and following the steps, I can’t show anything other than the startup background, I attach the data from my terminal.

Launching lib/main.dart on sdk gphone x86 arm in debug mode…
Running Gradle task ‘assembleDebug’…
Note: /Users/oswaldocfr/flutter/.pub-cache/hosted/pub.dartlang.org/audio_session-0.1.0/android/src/main/java/com/ryanheise/audio_session/AudioSessionPlugin.java uses or overrides a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
Note: /Users/oswaldocfr/flutter/.pub-cache/hosted/pub.dartlang.org/firebase_core-1.0.2/android/src/main/java/io/flutter/plugins/firebase/core/FlutterFirebaseCorePlugin.java uses or overrides a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
Note: /Users/oswaldocfr/flutter/.pub-cache/hosted/pub.dartlang.org/firebase_auth-1.0.1/android/src/main/java/io/flutter/plugins/firebase/auth/FlutterFirebaseAuthPlugin.java uses or overrides a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
Note: /Users/oswaldocfr/flutter/.pub-cache/hosted/pub.dartlang.org/google_sign_in-5.0.1/android/src/main/java/io/flutter/plugins/googlesignin/GoogleSignInPlugin.java uses or overrides a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
Note: Some input files use or override a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
Note: Some input files use or override a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
Note: /Users/oswaldocfr/flutter/.pub-cache/hosted/pub.dartlang.org/google_maps_flutter-2.0.1/android/src/main/java/io/flutter/plugins/googlemaps/Convert.java uses or overrides a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
Note: /Users/oswaldocfr/flutter/.pub-cache/hosted/pub.dartlang.org/google_maps_flutter-2.0.1/android/src/main/java/io/flutter/plugins/googlemaps/TileProviderController.java uses unchecked or unsafe operations.
Note: Recompile with -Xlint:unchecked for details.
✓ Built build/app/outputs/flutter-apk/app-debug.apk.
Installing build/app/outputs/flutter-apk/app.apk…
Debug service listening on ws://127.0.0.1:57016/3S9–QXJu1E=/ws
Syncing files to device sdk gphone x86 arm…
E/GraphResponse( 7846): {HttpStatus: 400, errorCode: 100, subErrorCode: 33, errorType: GraphMethodException, errorMessage: Unsupported get request. Object with ID ‘866704613752405’ does not exist, cannot be loaded due to missing permissions, or does not support this operation. Please read the Graph API documentation at Graph API - Documentation - Facebook for Developers}
I/flutter ( 7846): *** Request ***
I/flutter ( 7846): uri: https://labahiasecreta.lavilla.pe/wp-json/app-builder/v1/categories?page=1&search=&parent=0&per_page=10&hide_empty=false
I/flutter ( 7846):
I/flutter ( 7846): *** Request ***
I/flutter ( 7846): uri: https://labahiasecreta.lavilla.pe/wp-json/app-builder/v1/settings
I/flutter ( 7846):
I/flutter ( 7846): Auth token is null
I/flutter ( 7846): Auth token is null
I/flutter ( 7846): *** Response ***
I/flutter ( 7846): uri: https://labahiasecreta.lavilla.pe/wp-json/app-builder/v1/categories?page=1&search=&parent=0&per_page=10&hide_empty=false
I/flutter ( 7846):
I/flutter ( 7846): *** Response ***
I/flutter ( 7846): uri: https://labahiasecreta.lavilla.pe/wp-json/app-builder/v1/settings
I/flutter ( 7846):
E/flutter ( 7846): [ERROR:flutter/lib/ui/ui_dart_state.cc(186)] Unhandled Exception: type ‘List’ is not a subtype of type ‘Map<String, dynamic>’
E/flutter ( 7846): #0 _SettingStore.setSetting (package:cirilla/store/setting/setting_store.dart:182:89)
E/flutter ( 7846): #1 _$SettingStore.setSetting (package:cirilla/store/setting/setting_store.g.dart:293:20)
E/flutter ( 7846): #2 _SettingStore.getSetting (package:cirilla/store/setting/setting_store.dart:152:7)
E/flutter ( 7846):
E/flutter ( 7846): #3 AsyncAction.run (package:mobx/src/api/async/async_action.dart:29:14)
E/flutter ( 7846):
E/flutter ( 7846):
I/flutter ( 7846): *** Request ***
I/flutter ( 7846): uri: https://labahiasecreta.lavilla.pe/wp-json/wc/v3/products?page=1&per_page=8&status=publish&order=desc&orderby=date&featured=true
I/flutter ( 7846):
I/flutter ( 7846): *** Request ***
I/flutter ( 7846): uri: https://labahiasecreta.lavilla.pe/wp-json/wc/store/cart?cart_key=rXdxHaZgN
I/flutter ( 7846):
I/flutter ( 7846): Auth token is null
I/flutter ( 7846): *** Response ***
I/flutter ( 7846): uri: https://labahiasecreta.lavilla.pe/wp-json/wc/store/cart?cart_key=rXdxHaZgN
I/flutter ( 7846):
I/flutter ( 7846): *** Response ***
I/flutter ( 7846): uri: https://labahiasecreta.lavilla.pe/wp-json/wc/v3/products?page=1&per_page=8&status=publish&order=desc&orderby=date&featured=true&consumer_key=ck_50c407c73de8c2344bc9e80483356bb5c401697b&consumer_secret=cs_4825a48d8ed0efc116696be1e7f41e1bceddecdf
I/flutter ( 7846):

@Doxec you should create a least one template and active it in app builder plugin.

Thanks

@ngocdt

I got it


hi there i have create one template but never see any product ,app launch success android ios both as well web browser but stuck in cirilla logo,kindly update thanks

Have you https://yourdomain.com/ in your app.js file? / should be at the end and https is required.

same problem


its done already

√ Built build\app\outputs\flutter-apk\app-debug.apk.
Installing build\app\outputs\flutter-apk\app.apk…
Debug service listening on ws://127.0.0.1:53690/dYYFzgNgct8=/ws
Syncing files to device Redmi Note 7…
W/BpBinder( 4420): Slow Binder: BpBinder transact took 3916 ms, interface=android.content.IContentProvider, code=1 oneway=false
W/BpBinder( 4420): Slow Binder: BpBinder transact took 2056 ms, interface=android.content.IContentProvider, code=1 oneway=false
W/BpBinder( 4420): Slow Binder: BpBinder transact took 3969 ms, interface=android.content.IContentProvider, code=1 oneway=false
I/o.rnlab.cirill( 4420): ProcessProfilingInfo new_methods=1757 is saved saved_to_disk=1 resolve_classes_delay=8000
I/flutter ( 4420): *** Request ***
I/flutter ( 4420): uri: https://mrsouk.com/wp-json/app-builder/v1/categories?page=1&search=&parent=0&per_page=10&hide_empty=false
I/flutter ( 4420):
I/flutter ( 4420): *** Request ***
I/flutter ( 4420): uri: https://mrsouk.com/wp-json/app-builder/v1/settings
I/flutter ( 4420):
I/flutter ( 4420): Auth token is null
I/flutter ( 4420): Auth token is null
I/flutter ( 4420): *** Response ***
I/flutter ( 4420): uri: https://mrsouk.com/wp-json/app-builder/v1/settings
I/flutter ( 4420):
E/flutter ( 4420): [ERROR:flutter/lib/ui/ui_dart_state.cc(186)] Unhandled Exception: type ‘List’ is not a subtype of type ‘Map<String, dynamic>’
E/flutter ( 4420): #0 _SettingStore.setSetting (package:cirilla/store/setting/setting_store.dart:182:89)
E/flutter ( 4420): #1 _$SettingStore.setSetting (package:cirilla/store/setting/setting_store.g.dart:293:20)
E/flutter ( 4420): #2 _SettingStore.getSetting (package:cirilla/store/setting/setting_store.dart:152:7)
E/flutter ( 4420):
E/flutter ( 4420): #3 AsyncAction.run (package:mobx/src/api/async/async_action.dart:29:14)
E/flutter ( 4420):
E/flutter ( 4420):
I/flutter ( 4420): *** Response ***
I/flutter ( 4420): uri: https://mrsouk.com/wp-json/app-builder/v1/categories?page=1&search=&parent=0&per_page=10&hide_empty=false
I/flutter ( 4420):

======== Exception caught by rendering library =====================================================
The following assertion was thrown during performLayout():
‘package:flutter/src/rendering/viewport.dart’: Failed assertion: line 1861 pos 16: ‘constraints.hasBoundedHeight’: is not true.

Either the assertion indicates an error in the framework itself, or we should provide substantially more information in this error message to help you determine and fix the underlying cause.
In either case, please report this assertion by filing a bug on GitHub:
https://github.com/flutter/flutter/issues/new?template=2_bug.md

The relevant error-causing widget was:
ListView file:///C:/Users/Al%20Namal/Documents/GitHub/cirilla_flutter/cirilla/lib/widgets/builder/product/layout/layout_carousel.dart:30:21
When the exception was thrown, this was the stack:
#2 RenderShrinkWrappingViewport.performLayout (package:flutter/src/rendering/viewport.dart:1861:16)
#3 RenderObject.layout (package:flutter/src/rendering/object.dart:1784:7)
#4 RenderProxyBoxMixin.performLayout (package:flutter/src/rendering/proxy_box.dart:118:14)
#5 RenderObject.layout (package:flutter/src/rendering/object.dart:1784:7)
#6 RenderProxyBoxMixin.performLayout (package:flutter/src/rendering/proxy_box.dart:118:14)

The following RenderObject was being processed when the exception was fired: RenderShrinkWrappingViewport#07570 relayoutBoundary=up18 NEEDS-LAYOUT NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE
… needs compositing
… parentData: (can use size)
… constraints: BoxConstraints(0.0<=w<=392.7, 0.0<=h<=Infinity)
… size: MISSING
… axisDirection: right
… crossAxisDirection: down
… offset: ScrollPositionWithSingleContext#29d2e(offset: 0.0, range: null…null, viewport: null, ScrollableState, ClampingScrollPhysics → RangeMaintainingScrollPhysics, IdleScrollActivity#4cd0c, ScrollDirection.idle)
RenderObject: RenderShrinkWrappingViewport#07570 relayoutBoundary=up18 NEEDS-LAYOUT NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE
needs compositing
parentData: (can use size)
constraints: BoxConstraints(0.0<=w<=392.7, 0.0<=h<=Infinity)
size: MISSING
axisDirection: right
crossAxisDirection: down
offset: ScrollPositionWithSingleContext#29d2e(offset: 0.0, range: null…null, viewport: null, ScrollableState, ClampingScrollPhysics → RangeMaintainingScrollPhysics, IdleScrollActivity#4cd0c, ScrollDirection.idle)
… child 0: RenderSliverPadding#e111d NEEDS-LAYOUT NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE
… parentData: layoutOffset=None
… constraints: MISSING
… geometry: null
… padding: EdgeInsets.zero
… textDirection: ltr
… child: RenderSliverList#52403 NEEDS-LAYOUT NEEDS-PAINT
… parentData: paintOffset=Offset(0.0, 0.0)
… constraints: MISSING
… geometry: null
… no children current live

======== Exception caught by rendering library =====================================================
The following assertion was thrown during performLayout():
RenderBox was not laid out: RenderShrinkWrappingViewport#07570 relayoutBoundary=up18 NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE
‘package:flutter/src/rendering/box.dart’:
Failed assertion: line 1940 pos 12: ‘hasSize’

Either the assertion indicates an error in the framework itself, or we should provide substantially more information in this error message to help you determine and fix the underlying cause.
In either case, please report this assertion by filing a bug on GitHub:
https://github.com/flutter/flutter/issues/new?template=2_bug.md

The relevant error-causing widget was:
ListView file:///C:/Users/Al%20Namal/Documents/GitHub/cirilla_flutter/cirilla/lib/widgets/builder/product/layout/layout_carousel.dart:30:21
When the exception was thrown, this was the stack:
#2 RenderBox.size (package:flutter/src/rendering/box.dart:1940:12)
#3 RenderProxyBoxMixin.performLayout (package:flutter/src/rendering/proxy_box.dart:119:21)
#4 RenderObject.layout (package:flutter/src/rendering/object.dart:1784:7)
#5 RenderProxyBoxMixin.performLayout (package:flutter/src/rendering/proxy_box.dart:118:14)
#6 RenderObject.layout (package:flutter/src/rendering/object.dart:1784:7)

The following RenderObject was being processed when the exception was fired: RenderIgnorePointer#f78e2 relayoutBoundary=up17 NEEDS-LAYOUT NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE
… parentData: (can use size)
… constraints: BoxConstraints(0.0<=w<=392.7, 0.0<=h<=Infinity)
… size: MISSING
… ignoring: false
… ignoringSemantics: false
RenderObject: RenderIgnorePointer#f78e2 relayoutBoundary=up17 NEEDS-LAYOUT NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE
parentData: (can use size)
constraints: BoxConstraints(0.0<=w<=392.7, 0.0<=h<=Infinity)
size: MISSING
ignoring: false
ignoringSemantics: false
… child: RenderShrinkWrappingViewport#07570 relayoutBoundary=up18 NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE
… needs compositing
… parentData: (can use size)
… constraints: BoxConstraints(0.0<=w<=392.7, 0.0<=h<=Infinity)
… size: MISSING
… axisDirection: right
… crossAxisDirection: down
… offset: ScrollPositionWithSingleContext#29d2e(offset: 0.0, range: null…null, viewport: null, ScrollableState, ClampingScrollPhysics → RangeMaintainingScrollPhysics, IdleScrollActivity#4cd0c, ScrollDirection.idle)
… child 0: RenderSliverPadding#e111d NEEDS-LAYOUT NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE
… parentData: layoutOffset=None
… constraints: MISSING
… geometry: null
… padding: EdgeInsets.zero
… textDirection: ltr
… child: RenderSliverList#52403 NEEDS-LAYOUT NEEDS-PAINT
… parentData: paintOffset=Offset(0.0, 0.0)
… constraints: MISSING
… geometry: null
… no children current live

======== Exception caught by rendering library =====================================================
The following assertion was thrown during performLayout():
RenderBox was not laid out: RenderIgnorePointer#f78e2 relayoutBoundary=up17 NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE
‘package:flutter/src/rendering/box.dart’:
Failed assertion: line 1940 pos 12: ‘hasSize’

Either the assertion indicates an error in the framework itself, or we should provide substantially more information in this error message to help you determine and fix the underlying cause.
In either case, please report this assertion by filing a bug on GitHub:
https://github.com/flutter/flutter/issues/new?template=2_bug.md

The relevant error-causing widget was:
ListView file:///C:/Users/Al%20Namal/Documents/GitHub/cirilla_flutter/cirilla/lib/widgets/builder/product/layout/layout_carousel.dart:30:21
When the exception was thrown, this was the stack:
#2 RenderBox.size (package:flutter/src/rendering/box.dart:1940:12)
#3 RenderProxyBoxMixin.performLayout (package:flutter/src/rendering/proxy_box.dart:119:21)
#4 RenderObject.layout (package:flutter/src/rendering/object.dart:1784:7)
#5 RenderProxyBoxMixin.performLayout (package:flutter/src/rendering/proxy_box.dart:118:14)
#6 RenderObject.layout (package:flutter/src/rendering/object.dart:1784:7)

The following RenderObject was being processed when the exception was fired: RenderSemanticsAnnotations#bdfca relayoutBoundary=up16 NEEDS-LAYOUT NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE
… parentData: (can use size)
… constraints: BoxConstraints(0.0<=w<=392.7, 0.0<=h<=Infinity)
… size: MISSING
RenderObject: RenderSemanticsAnnotations#bdfca relayoutBoundary=up16 NEEDS-LAYOUT NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE
parentData: (can use size)
constraints: BoxConstraints(0.0<=w<=392.7, 0.0<=h<=Infinity)
size: MISSING
… child: RenderIgnorePointer#f78e2 relayoutBoundary=up17 NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE
… parentData: (can use size)
… constraints: BoxConstraints(0.0<=w<=392.7, 0.0<=h<=Infinity)
… size: MISSING
… ignoring: false
… ignoringSemantics: false
… child: RenderShrinkWrappingViewport#07570 relayoutBoundary=up18 NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE
… needs compositing
… parentData: (can use size)
… constraints: BoxConstraints(0.0<=w<=392.7, 0.0<=h<=Infinity)
… size: MISSING
… axisDirection: right
… crossAxisDirection: down
… offset: ScrollPositionWithSingleContext#29d2e(offset: 0.0, range: null…null, viewport: null, ScrollableState, ClampingScrollPhysics → RangeMaintainingScrollPhysics, IdleScrollActivity#4cd0c, ScrollDirection.idle)
… child 0: RenderSliverPadding#e111d NEEDS-LAYOUT NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE
… parentData: layoutOffset=None
… constraints: MISSING
… geometry: null
… padding: EdgeInsets.zero
… textDirection: ltr
… child: RenderSliverList#52403 NEEDS-LAYOUT NEEDS-PAINT
… parentData: paintOffset=Offset(0.0, 0.0)
… constraints: MISSING
… geometry: null
… no children current live

======== Exception caught by rendering library =====================================================
The following assertion was thrown during performLayout():
RenderBox was not laid out: RenderSemanticsAnnotations#bdfca relayoutBoundary=up16 NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE
‘package:flutter/src/rendering/box.dart’:
Failed assertion: line 1940 pos 12: ‘hasSize’

Either the assertion indicates an error in the framework itself, or we should provide substantially more information in this error message to help you determine and fix the underlying cause.
In either case, please report this assertion by filing a bug on GitHub:
https://github.com/flutter/flutter/issues/new?template=2_bug.md

The relevant error-causing widget was:
ListView file:///C:/Users/Al%20Namal/Documents/GitHub/cirilla_flutter/cirilla/lib/widgets/builder/product/layout/layout_carousel.dart:30:21
When the exception was thrown, this was the stack:
#2 RenderBox.size (package:flutter/src/rendering/box.dart:1940:12)
#3 RenderProxyBoxMixin.performLayout (package:flutter/src/rendering/proxy_box.dart:119:21)
#4 RenderObject.layout (package:flutter/src/rendering/object.dart:1784:7)
#5 RenderProxyBoxMixin.performLayout (package:flutter/src/rendering/proxy_box.dart:118:14)
#6 RenderObject.layout (package:flutter/src/rendering/object.dart:1784:7)

The following RenderObject was being processed when the exception was fired: RenderPointerListener#5f933 relayoutBoundary=up15 NEEDS-LAYOUT NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE
… parentData: (can use size)
… constraints: BoxConstraints(0.0<=w<=392.7, 0.0<=h<=Infinity)
… size: MISSING
… behavior: opaque
… listeners: down
RenderObject: RenderPointerListener#5f933 relayoutBoundary=up15 NEEDS-LAYOUT NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE
parentData: (can use size)
constraints: BoxConstraints(0.0<=w<=392.7, 0.0<=h<=Infinity)
size: MISSING
behavior: opaque
listeners: down
… child: RenderSemanticsAnnotations#bdfca relayoutBoundary=up16 NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE
… parentData: (can use size)
… constraints: BoxConstraints(0.0<=w<=392.7, 0.0<=h<=Infinity)
… size: MISSING
… child: RenderIgnorePointer#f78e2 relayoutBoundary=up17 NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE
… parentData: (can use size)
… constraints: BoxConstraints(0.0<=w<=392.7, 0.0<=h<=Infinity)
… size: MISSING
… ignoring: false
… ignoringSemantics: false
… child: RenderShrinkWrappingViewport#07570 relayoutBoundary=up18 NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE
… needs compositing
… parentData: (can use size)
… constraints: BoxConstraints(0.0<=w<=392.7, 0.0<=h<=Infinity)
… size: MISSING
… axisDirection: right
… crossAxisDirection: down
… offset: ScrollPositionWithSingleContext#29d2e(offset: 0.0, range: null…null, viewport: null, ScrollableState, ClampingScrollPhysics → RangeMaintainingScrollPhysics, IdleScrollActivity#4cd0c, ScrollDirection.idle)
… child 0: RenderSliverPadding#e111d NEEDS-LAYOUT NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE
… parentData: layoutOffset=None
… constraints: MISSING
… geometry: null
… padding: EdgeInsets.zero
… textDirection: ltr

======== Exception caught by rendering library =====================================================
The following assertion was thrown during performLayout():
RenderBox was not laid out: RenderPointerListener#5f933 relayoutBoundary=up15 NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE
‘package:flutter/src/rendering/box.dart’:
Failed assertion: line 1940 pos 12: ‘hasSize’

Either the assertion indicates an error in the framework itself, or we should provide substantially more information in this error message to help you determine and fix the underlying cause.
In either case, please report this assertion by filing a bug on GitHub:
https://github.com/flutter/flutter/issues/new?template=2_bug.md

The relevant error-causing widget was:
ListView file:///C:/Users/Al%20Namal/Documents/GitHub/cirilla_flutter/cirilla/lib/widgets/builder/product/layout/layout_carousel.dart:30:21
When the exception was thrown, this was the stack:
#2 RenderBox.size (package:flutter/src/rendering/box.dart:1940:12)
#3 RenderProxyBoxMixin.performLayout (package:flutter/src/rendering/proxy_box.dart:119:21)
#4 RenderObject.layout (package:flutter/src/rendering/object.dart:1784:7)
#5 RenderProxyBoxMixin.performLayout (package:flutter/src/rendering/proxy_box.dart:118:14)
#6 RenderObject.layout (package:flutter/src/rendering/object.dart:1784:7)

The following RenderObject was being processed when the exception was fired: RenderSemanticsGestureHandler#2ad85 relayoutBoundary=up14 NEEDS-LAYOUT NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE
… parentData: (can use size)
… constraints: BoxConstraints(0.0<=w<=392.7, 0.0<=h<=Infinity)
… size: MISSING
… gestures:
RenderObject: RenderSemanticsGestureHandler#2ad85 relayoutBoundary=up14 NEEDS-LAYOUT NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE
parentData: (can use size)
constraints: BoxConstraints(0.0<=w<=392.7, 0.0<=h<=Infinity)
size: MISSING
gestures:
… child: RenderPointerListener#5f933 relayoutBoundary=up15 NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE
… parentData: (can use size)
… constraints: BoxConstraints(0.0<=w<=392.7, 0.0<=h<=Infinity)
… size: MISSING
… behavior: opaque
… listeners: down
… child: RenderSemanticsAnnotations#bdfca relayoutBoundary=up16 NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE
… parentData: (can use size)
… constraints: BoxConstraints(0.0<=w<=392.7, 0.0<=h<=Infinity)
… size: MISSING
… child: RenderIgnorePointer#f78e2 relayoutBoundary=up17 NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE
… parentData: (can use size)
… constraints: BoxConstraints(0.0<=w<=392.7, 0.0<=h<=Infinity)
… size: MISSING
… ignoring: false
… ignoringSemantics: false
… child: RenderShrinkWrappingViewport#07570 relayoutBoundary=up18 NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE
… needs compositing
… parentData: (can use size)
… constraints: BoxConstraints(0.0<=w<=392.7, 0.0<=h<=Infinity)
… size: MISSING
… axisDirection: right
… crossAxisDirection: down
… offset: ScrollPositionWithSingleContext#29d2e(offset: 0.0, range: null…null, viewport: null, ScrollableState, ClampingScrollPhysics → RangeMaintainingScrollPhysics, IdleScrollActivity#4cd0c, ScrollDirection.idle)

======== Exception caught by rendering library =====================================================
The following assertion was thrown during performLayout():
RenderBox was not laid out: RenderSemanticsGestureHandler#2ad85 relayoutBoundary=up14 NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE
‘package:flutter/src/rendering/box.dart’:
Failed assertion: line 1940 pos 12: ‘hasSize’

Either the assertion indicates an error in the framework itself, or we should provide substantially more information in this error message to help you determine and fix the underlying cause.
In either case, please report this assertion by filing a bug on GitHub:
https://github.com/flutter/flutter/issues/new?template=2_bug.md

The relevant error-causing widget was:
ListView file:///C:/Users/Al%20Namal/Documents/GitHub/cirilla_flutter/cirilla/lib/widgets/builder/product/layout/layout_carousel.dart:30:21
When the exception was thrown, this was the stack:
#2 RenderBox.size (package:flutter/src/rendering/box.dart:1940:12)
#3 RenderProxyBoxMixin.performLayout (package:flutter/src/rendering/proxy_box.dart:119:21)
#4 RenderObject.layout (package:flutter/src/rendering/object.dart:1784:7)
#5 RenderProxyBoxMixin.performLayout (package:flutter/src/rendering/proxy_box.dart:118:14)
#6 RenderObject.layout (package:flutter/src/rendering/object.dart:1784:7)

The following RenderObject was being processed when the exception was fired: RenderPointerListener#5f04f relayoutBoundary=up13 NEEDS-LAYOUT NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE
… parentData: (can use size)
… constraints: BoxConstraints(0.0<=w<=392.7, 0.0<=h<=Infinity)
… size: MISSING
… behavior: deferToChild
… listeners: signal
RenderObject: RenderPointerListener#5f04f relayoutBoundary=up13 NEEDS-LAYOUT NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE
parentData: (can use size)
constraints: BoxConstraints(0.0<=w<=392.7, 0.0<=h<=Infinity)
size: MISSING
behavior: deferToChild
listeners: signal
… child: RenderSemanticsGestureHandler#2ad85 relayoutBoundary=up14 NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE
… parentData: (can use size)
… constraints: BoxConstraints(0.0<=w<=392.7, 0.0<=h<=Infinity)
… size: MISSING
… gestures:
… child: RenderPointerListener#5f933 relayoutBoundary=up15 NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE
… parentData: (can use size)
… constraints: BoxConstraints(0.0<=w<=392.7, 0.0<=h<=Infinity)
… size: MISSING
… behavior: opaque
… listeners: down
… child: RenderSemanticsAnnotations#bdfca relayoutBoundary=up16 NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE
… parentData: (can use size)
… constraints: BoxConstraints(0.0<=w<=392.7, 0.0<=h<=Infinity)
… size: MISSING
… child: RenderIgnorePointer#f78e2 relayoutBoundary=up17 NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE
… parentData: (can use size)
… constraints: BoxConstraints(0.0<=w<=392.7, 0.0<=h<=Infinity)
… size: MISSING
… ignoring: false
… ignoringSemantics: false

======== Exception caught by rendering library =====================================================
The following assertion was thrown during performLayout():
RenderBox was not laid out: RenderPointerListener#5f04f relayoutBoundary=up13 NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE
‘package:flutter/src/rendering/box.dart’:
Failed assertion: line 1940 pos 12: ‘hasSize’

Either the assertion indicates an error in the framework itself, or we should provide substantially more information in this error message to help you determine and fix the underlying cause.
In either case, please report this assertion by filing a bug on GitHub:
https://github.com/flutter/flutter/issues/new?template=2_bug.md

The relevant error-causing widget was:
ListView file:///C:/Users/Al%20Namal/Documents/GitHub/cirilla_flutter/cirilla/lib/widgets/builder/product/layout/layout_carousel.dart:30:21
When the exception was thrown, this was the stack:
#2 RenderBox.size (package:flutter/src/rendering/box.dart:1940:12)
#3 RenderProxyBoxMixin.performLayout (package:flutter/src/rendering/proxy_box.dart:119:21)
#4 RenderObject.layout (package:flutter/src/rendering/object.dart:1784:7)
#5 RenderProxyBoxMixin.performLayout (package:flutter/src/rendering/proxy_box.dart:118:14)
#6 RenderObject.layout (package:flutter/src/rendering/object.dart:1784:7)

The following RenderObject was being processed when the exception was fired: _RenderScrollSemantics#4ce4d relayoutBoundary=up12 NEEDS-LAYOUT NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE
… parentData: (can use size)
… constraints: BoxConstraints(0.0<=w<=392.7, 0.0<=h<=Infinity)
… semantic boundary
… size: MISSING
RenderObject: _RenderScrollSemantics#4ce4d relayoutBoundary=up12 NEEDS-LAYOUT NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE
parentData: (can use size)
constraints: BoxConstraints(0.0<=w<=392.7, 0.0<=h<=Infinity)
semantic boundary
size: MISSING
… child: RenderPointerListener#5f04f relayoutBoundary=up13 NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE
… parentData: (can use size)
… constraints: BoxConstraints(0.0<=w<=392.7, 0.0<=h<=Infinity)
… size: MISSING
… behavior: deferToChild
… listeners: signal
… child: RenderSemanticsGestureHandler#2ad85 relayoutBoundary=up14 NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE
… parentData: (can use size)
… constraints: BoxConstraints(0.0<=w<=392.7, 0.0<=h<=Infinity)
… size: MISSING
… gestures:
… child: RenderPointerListener#5f933 relayoutBoundary=up15 NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE
… parentData: (can use size)
… constraints: BoxConstraints(0.0<=w<=392.7, 0.0<=h<=Infinity)
… size: MISSING
… behavior: opaque
… listeners: down
… child: RenderSemanticsAnnotations#bdfca relayoutBoundary=up16 NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE
… parentData: (can use size)
… constraints: BoxConstraints(0.0<=w<=392.7, 0.0<=h<=Infinity)
… size: MISSING

======== Exception caught by rendering library =====================================================
The following assertion was thrown during performLayout():
RenderBox was not laid out: _RenderScrollSemantics#4ce4d relayoutBoundary=up12 NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE
‘package:flutter/src/rendering/box.dart’:
Failed assertion: line 1940 pos 12: ‘hasSize’

Either the assertion indicates an error in the framework itself, or we should provide substantially more information in this error message to help you determine and fix the underlying cause.
In either case, please report this assertion by filing a bug on GitHub:
https://github.com/flutter/flutter/issues/new?template=2_bug.md

The relevant error-causing widget was:
ListView file:///C:/Users/Al%20Namal/Documents/GitHub/cirilla_flutter/cirilla/lib/widgets/builder/product/layout/layout_carousel.dart:30:21
When the exception was thrown, this was the stack:
#2 RenderBox.size (package:flutter/src/rendering/box.dart:1940:12)
#3 RenderProxyBoxMixin.performLayout (package:flutter/src/rendering/proxy_box.dart:119:21)
#4 RenderObject.layout (package:flutter/src/rendering/object.dart:1784:7)
#5 RenderProxyBoxMixin.performLayout (package:flutter/src/rendering/proxy_box.dart:118:14)
#6 RenderCustomPaint.performLayout (package:flutter/src/rendering/custom_paint.dart:546:11)

The following RenderObject was being processed when the exception was fired: RenderRepaintBoundary#aab11 relayoutBoundary=up11 NEEDS-LAYOUT NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE
… needs compositing
… parentData: (can use size)
… constraints: BoxConstraints(0.0<=w<=392.7, 0.0<=h<=Infinity)
… size: MISSING
… usefulness ratio: no metrics collected yet (never painted)
RenderObject: RenderRepaintBoundary#aab11 relayoutBoundary=up11 NEEDS-LAYOUT NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE
needs compositing
parentData: (can use size)
constraints: BoxConstraints(0.0<=w<=392.7, 0.0<=h<=Infinity)
size: MISSING
usefulness ratio: no metrics collected yet (never painted)
… child: _RenderScrollSemantics#4ce4d relayoutBoundary=up12 NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE
… parentData: (can use size)
… constraints: BoxConstraints(0.0<=w<=392.7, 0.0<=h<=Infinity)
… semantic boundary
… size: MISSING
… child: RenderPointerListener#5f04f relayoutBoundary=up13 NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE
… parentData: (can use size)
… constraints: BoxConstraints(0.0<=w<=392.7, 0.0<=h<=Infinity)
… size: MISSING
… behavior: deferToChild
… listeners: signal
… child: RenderSemanticsGestureHandler#2ad85 relayoutBoundary=up14 NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE
… parentData: (can use size)
… constraints: BoxConstraints(0.0<=w<=392.7, 0.0<=h<=Infinity)
… size: MISSING
… gestures:
… child: RenderPointerListener#5f933 relayoutBoundary=up15 NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE
… parentData: (can use size)
… constraints: BoxConstraints(0.0<=w<=392.7, 0.0<=h<=Infinity)
… size: MISSING
… behavior: opaque
… listeners: down

======== Exception caught by rendering library =====================================================
The following assertion was thrown during performLayout():
RenderBox was not laid out: RenderRepaintBoundary#aab11 relayoutBoundary=up11 NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE
‘package:flutter/src/rendering/box.dart’:
Failed assertion: line 1940 pos 12: ‘hasSize’

Either the assertion indicates an error in the framework itself, or we should provide substantially more information in this error message to help you determine and fix the underlying cause.
In either case, please report this assertion by filing a bug on GitHub:
https://github.com/flutter/flutter/issues/new?template=2_bug.md

The relevant error-causing widget was:
ListView file:///C:/Users/Al%20Namal/Documents/GitHub/cirilla_flutter/cirilla/lib/widgets/builder/product/layout/layout_carousel.dart:30:21
When the exception was thrown, this was the stack:
#2 RenderBox.size (package:flutter/src/rendering/box.dart:1940:12)
#3 RenderProxyBoxMixin.performLayout (package:flutter/src/rendering/proxy_box.dart:119:21)
#4 RenderCustomPaint.performLayout (package:flutter/src/rendering/custom_paint.dart:546:11)
#5 RenderObject.layout (package:flutter/src/rendering/object.dart:1784:7)
#6 RenderProxyBoxMixin.performLayout (package:flutter/src/rendering/proxy_box.dart:118:14)

The following RenderObject was being processed when the exception was fired: RenderCustomPaint#17c78 relayoutBoundary=up10 NEEDS-LAYOUT NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE
… parentData: (can use size)
… constraints: BoxConstraints(0.0<=w<=392.7, 0.0<=h<=Infinity)
… size: MISSING
RenderObject: RenderCustomPaint#17c78 relayoutBoundary=up10 NEEDS-LAYOUT NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE
parentData: (can use size)
constraints: BoxConstraints(0.0<=w<=392.7, 0.0<=h<=Infinity)
size: MISSING
… child: RenderRepaintBoundary#aab11 relayoutBoundary=up11 NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE
… needs compositing
… parentData: (can use size)
… constraints: BoxConstraints(0.0<=w<=392.7, 0.0<=h<=Infinity)
… size: MISSING
… usefulness ratio: no metrics collected yet (never painted)
… child: _RenderScrollSemantics#4ce4d relayoutBoundary=up12 NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE
… parentData: (can use size)
… constraints: BoxConstraints(0.0<=w<=392.7, 0.0<=h<=Infinity)
… semantic boundary
… size: MISSING
… child: RenderPointerListener#5f04f relayoutBoundary=up13 NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE
… parentData: (can use size)
… constraints: BoxConstraints(0.0<=w<=392.7, 0.0<=h<=Infinity)
… size: MISSING
… behavior: deferToChild
… listeners: signal
… child: RenderSemanticsGestureHandler#2ad85 relayoutBoundary=up14 NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE
… parentData: (can use size)
… constraints: BoxConstraints(0.0<=w<=392.7, 0.0<=h<=Infinity)
… size: MISSING
… gestures:

I/flutter ( 4420): *** Request ***
I/flutter ( 4420): uri: https://mrsouk.com/wp-json/wc/v3/products?page=1&category=4625&per_page=20&status=publish&order=desc&orderby=date
I/flutter ( 4420):

@Doxec @mrsouk Could you upgrade App builder to 1.0.4 and click to here

Download latest Cirilla for App builder then refresh browser => try again.

I checked on our demo the app working normal in category screen

Thanks

new problem!

======== Exception caught by widgets library =======================================================
The following NoSuchMethodError was thrown building CirillaProductItem(dirty, dependencies: [_InheritedProviderScope, _InheritedProviderScope, _LocalizationsScope-[GlobalKey#4906f], _InheritedTheme, _InheritedProviderScope], state: _CirillaProductItemState#1149d):
The method ‘[]’ was called on null.
Receiver: null
Tried calling:

The relevant error-causing widget was:
CirillaProductItem file:///Users/oswaldocfr/Documents/Proyectos/La%20Bahia%20Secreta/app/cirilla/lib/screens/product_list/widgets/product_list.dart:57:9
When the exception was thrown, this was the stack:
#0 Object.noSuchMethod (dart:core-patch/object_patch.dart:54:5)
#1 formatCurrency (package:cirilla/utils/currency_format.dart:27:34)
#2 ProductMixin.buildPrice (package:cirilla/mixins/product_mixin.dart:165:7)
#3 _CirillaProductItemState.build (package:cirilla/widgets/cirilla_product_item.dart:371:18)
#4 StatefulElement.build (package:flutter/src/widgets/framework.dart:4612:27)

I/flutter (15063): *** Request ***
I/flutter (15063): uri: https://labahiasecreta.lavilla.pe/wp-json/wc/v3/products/attributes?attrs=[{"taxonomy"%3A"product_cat"%2C"field"%3A"cat_id"%2C"terms"%3A[16]}]
I/flutter (15063):
I/flutter (15063): *** Response ***
I/flutter (15063): uri: https://labahiasecreta.lavilla.pe/wp-json/wc/v3/products/attributes?attrs=[{"taxonomy"%3A"product_cat"%2C"field"%3A"cat_id"%2C"terms"%3A[16]}]&consumer_key=ck_50c407c73de8c2344bc9e80483356bb5c401697b&consumer_secret=cs_4825a48d8ed0efc116696be1e7f41e1bceddecdf
I/flutter (15063):
I/flutter (15063): *** Request ***
I/flutter (15063): uri: https://labahiasecreta.lavilla.pe/wp-json/wc/v3/min-max-prices?category=16
I/flutter (15063):
I/flutter (15063): *** Response ***
I/flutter (15063): uri: https://labahiasecreta.lavilla.pe/wp-json/wc/v3/min-max-prices?category=16&consumer_key=ck_50c407c73de8c2344bc9e80483356bb5c401697b&consumer_secret=cs_4825a48d8ed0efc116696be1e7f41e1bceddecdf
I/flutter (15063):

@Doxec Yes, I found the issue our site support multi currency and your site now single. I will fix and update in today to Codecanyon.

Thanks

@ngocdt perfect, because I have several days without being able to advance with my project.

1 Like

Hi ngocdt I reached out to you few days back, I bought oreo fashion app, I want to disable web view checkout, I tried to do it on mobile builder it not working.