Optimization REST API from medium to large website

In version v1.3.9 we add Wordpress Object Cache that means the data fetch from list API will be cache:



But cached data will not be stored persistently across page loads unless you install a persistent caching plugin.

We are using Redis to cache object on our server install the demo http://wc.rnlab.io/

The steps we did:

  1. Install Redis on server
  2. Install Php Redis on server
  3. Install Redis plugin Redis Object Cache you can install W3 Total Cache plugin instead on website
  4. Active plugin and Active Object Cache
  5. add define('WP_CACHE', true) to your wp-config.php file


1 Like

@ngocdt , is 1.3.9 already released so we can apply these optimizations?
if not yet, is this applicable for previous versions?

Thank you,

@ali I not release yet. Will release soon.

1 Like

Approximately when will it come out?
Thank you

we used this your step we used redis object cache and add define in wp config but after add wp config wp true website will not working

This page isn’t working

ssbazaar.in is currently unable to handle this request.


Are you using VPS or Dedicated Server? If yes, you can find the issues on error logs.

It’s most likely, the PHP-FPM / FastCGI parameter not fillfult the Redis Cache to caused this issues.

Hi , Installed redis and php-redis as per the guideline . Still the loading time is almost 5 seconds to load product variations .

@arlun, @ananthamigo We are using Digital Ocean server to handle backend for Oreo fashion app. and other services like docs and forums.


Is this config correct?

App is still slow.

@cameronwilliamwilson The splash show when fetch setting data from server.

You can try this tool to check settings API response time: https://tools.pingdom.com/


OK I think Redis is working.

I need to compress image size? Loading very slow.

Yes, maybe Need optimal images